Mettre à jour son antivirus ou son antispam sous Debian stable

Suivez-moi sur Identi.ca : http://identi.ca/carlchenet

Certains logiciels nécessitent de petites évolutions plus ou moins régulières, commes les antivirus ou les antispams. Il apparaît évident que la durée de vie de la version stable de Debian est trop longue pour assurer à ce type de programmes de rester pleinement fonctionnel.

Grâce au dépôt debian-volatile, nous allons pouvoir mettre à jour facilement ces programmes au besoin, de façon à les conserver fonctionnels tout au long du cycle de vie de la Debian stable, sans avoir à requérir de manipulations fastidieuses pour aller chercher une version améliorée dans d’autres dépôts qui de plus n’interviennent que sur les bugs majeurs, la sécurité ou le rétroportage de versions supérieures.

Pour utiliser le dépôt debian-volatile sous Debian stable (actuellement Lenny), il est nécessaire de renseigner la ligne suivante dans votre fichier /etc/apt/sources.list :

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free



Pour que les utilisateurs soient avertis qu’un paquet mis à jour est disponible dans debian-volatile, un message est envoyé sur la liste de diffusion debian-volatile-announce. Vous bénéficiez ainsi d’une description synthétique des améliorations apportées par le nouveau paquet.

Voici quelques exemples de paquets mis à jour par debian-volatile :

  • spamassassin
  • clamav
  • tzdata
  • tor

Ce dépôt n’est donc pas à négliger pour maintenir votre Debian stable à jour sur ces logiciels qui peuvent s’avérer critiques pour votre infrastructure.

Publicités

5 réflexions au sujet de « Mettre à jour son antivirus ou son antispam sous Debian stable »

  1. Bonjour,

    Une question me vient à l’esprit quand je lis ce post: Pourquoi ne pas mettre à jour ces logiciels via les mécanismes d’update classiques (debian-security? debian-update?). Je ne suis pas utilisateur de debian, je ne connais pas les noms des dépôts de mise-à-jour, mais j’imagine que les paquets peuvent être mis à jour sans passer par un dépôt spécial.

    Peut-être y a-t-il une subtilité que je n’ai pas saisi.

    Merci pour ton blog et tes articles Linux Mag!

    1. cjlano: Le dépôt dédié à la stable n’est mis à jour qu’au moment des point releases, à intervalles plus ou moins réguliers, ce qui peut présenter un problème si clamav ou spamassassion a besoin d’être mis à jour de façon urgente.

      De plus la sécurité des logiciels présents dans debian-volatile est assurée par l’équipe de debian-volatile, non pas par l’équipe de sécurité.

      Le dépot debian-volatile apporte donc davantage de souplesse pour des applications nécessitant des mises à jour urgentes et irrégulières.

      > Merci pour ton blog et tes articles Linux Mag!

      Meurchi 🙂

    1. gui: le but de debian-volatile n’est pas de fournir la dernière version des paquets que ce dépôt contient, mais de mettre à jour simplement et efficacement le paquet de base dans la version stable.

      Il ne s’agit donc pas de faire rentrer une nouvelle version (donc instable au sens de Debian) mais de privilégier une version qu’on estime stable et apportant quelque chose par rapport à la version déjà présente dans la version stable.

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s