Première bêta de l’installeur de la prochaine version stable de Debian

Suivez-moi sur Identi.ca : http://identi.ca/carlchenet

L’équipe du Debian-Installer (D-I) a annoncé samedi dernier la disponibilité de la première version bêta du D-I qui permet l’installation de la prochaine version stable de Debian nommée Squeeze.

Le D-I est l’élément-clé de l’installation de la distribution et doit permettre à celle-ci de s’installer sur une gamme de machines aussi large que possible en offrant de très nombreuses options. Le D-I propose une installation en mode graphique ou en mode texte. Rappelons que ce dernier mode permet, entre autre, aux personnes malvoyantes ou aveugles d’installer elles-mêmes Debian.

Quelques éléments intéressants de cette nouvelle version bêta :

  • La version du noyau Linux sur lequel s’appuie l’installeur est désormais la 2.6.32.
  • L’outil de gestion des partitions GParted est maintenant est version 2.2.
  • Supports de nouvelles plateformes matérielles (Marvell GuruPlug, Marvell OpenRD-Ultimate).
  • Support pour les images iso hybrides (CDROM et clé USB).
  • D-I recherche maintenant des firmwares au format .deb dans le répertoire  firmware/ sur le média d’installation.
  • Les paquets Debian qui sont spécifiques à un matériel particulier sont maintenant installés automatiquement.
  • Plusieurs nouvelles langues supportées mais d’autres ont été supprimées par manque de contributeurs. 67 langues au total sont supportées.
  • Utilisation de udhcp comme client DHCP.
  • Le support de ReiserFS n’est plus inclus par défaut.

Comme nous l’avons dit, il s’agit ici de la première version de la bêta du nouveau D-I. N’hésitez donc pas à le tester et à faire remonter d’éventuels problèmes.

Comment faire pour tester ? Il s’agit de se rendre à cette adresse, de télécharger l’iso qui correspond à votre besoin – netinstall, format business card, format CD ou DVD, en choisissant bien votre plateforme matérielle – puis de l’installer à partir d’une machine virtuelle ou en gravant cet iso et en l’installant de façon classique. Vous pouvez ensuite faire un rapport d’installation (QCM court à remplir) en tapant la commande suivante dans un terminal :

$ reportbug installation-reports

Il faut pour cela avoir installé les paquets reportbug et installation-reports sur le système depuis lequel vous faites le rapport.

Cette version du D-I est dédiée à la mémoire de Frans Pop, décédé le 20 août 2010, membre actif de la communauté Debian et grand contributeur du D-I.

Publicités

17 réflexions au sujet de « Première bêta de l’installeur de la prochaine version stable de Debian »

  1. Petite question par rapport à cette beta.

    Pour ma part, je fais une Debian aux petits oignons, donc je n’installe que le système de base via l’installeur lorsque l’on arrive aux différents choix d’installation (Environnement de Bureau, Système de base…)

    Ayant dernièrement installé Debian sur mon laptop, l’installeur m’a également proposé « Ordinateur Portable ». Le problème, c’est que je ne sais pas du tout quels sont les paquets qui sont installés avec ce choix?

    Une idée?
    J’ai beau fouillé sur le site de Debian, je n’ai rien trouvé.

  2. Salut,

    Une petite question, sous debian squeeze nouveau 3D est utilisé?

    Car j’ai installé « libdrm-nouveau1 », et « xserver-xorg-video-nouveau » et quand je tape « glxinfo | grep « direct rendering » » j’ai le retour : « direct rendering: Yes ».

    J’ai testé avec un jeu 3D mais ça rame à mort ^^

    Merci également pour l’info je vais tester de nouveau kfreebsd 😀

  3. Oui je sais bien que nouveau est proposé dans squeeze mais est ce qu’ils ont ajoutés le support 3D à celui-ci?

    Car seul le support 2D dans nouveau est stable, la 3D est encore au stade expérimental mais on dirait qu’ils l’ont ajoutés d’après moi, c’est pas plus mal mais je voulait juste une confirmation ^^

  4. Pour avoir la 3D avec nouveau il faut installer le driver gallium correspondant.
    Le DirectRendering ne signifie pas forcément 3D.

  5. Bonjour a vous,
    Excélente nouvelle pour cette béta.
    J’ai une question a vous posé.
    Pensez-vous que mon matèriel peut-etre correctement utilisé:

    Processeur: Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz

    VGA compatible controller: nVidia Corporation G98M [GeForce G105M] (rev a2) (prog-if 00 [VGA controller])

    Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

    Network controller: Broadcom Corporation BCM43225 802.11b/g/n (rev 01)

    Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s